Rocket.net
← Back to status

Phoenix DC – Elevated Ambient Temperature

Resolved Aug 13, 2026 07:34 EDT

Incident Updates

  • Resolved 3 days ago · Aug 13, 2026 19:59 EDT

    Resolved: The Phoenix Data Center incident has been fully resolved. All affected servers have been restored and are back online. Our teams have completed the recovery efforts and are continuing to monitor the environment to ensure services remain stable. We sincerely apologize for the disruption and appreciate your patience and understanding while we worked to restore services. This incident is now resolved.

  • Identified 3 days ago · Aug 13, 2026 19:44 EDT

    We continue to work closely with our Phoenix data center provider as facility temperatures trend toward normal operating levels. Our engineering and support teams have all hands on deck checking infrastructure and working to bring offline devices back online. Recovery is actively progressing, and a number of servers and services have already been restored. We are continuing to work through the remaining affected infrastructure and will provide additional updates as more services are brought back online. Our teams remain actively engaged and are closely monitoring the environment to ensure restored services remain stable. We appreciate your patience and understanding as we continue working toward full service restoration. We will post further updates as the recovery progresses.

  • Identified 3 days ago · Aug 13, 2026 14:58 EDT

    We continue to monitor an ongoing incident affecting our Phoenix data center. Our data center provider has confirmed that elevated ambient temperatures in the facility were caused by multiple utility bump events associated with overnight storms in the area. On-site teams and vendors are actively working to restore adequate cooling and stabilize the affected infrastructure. As part of the recovery efforts: > Chiller D has been restored and has already resulted in a significant reduction in temperatures. > Additional cooling and heat-removal equipment is being deployed within the facility. > Restoration of Chiller C is underway. > Additional temporary chiller capacity and a backup generator are being deployed as part of the ongoing mitigation efforts. Our engineering and support teams remain in close contact with the facility and are monitoring affected systems as recovery progresses. We do not currently have a confirmed ETA for full restoration. We will continue to provide updates as we receive additional information from the facility and as services are restored. We apologize for the disruption and appreciate your patience and understanding while this incident is being resolved.

  • Identified 4 days ago · Aug 13, 2026 11:34 EDT

    We are continuing to monitor an ongoing issue affecting our Phoenix Data Center. Our System engineers team remains actively engaged and is working together with our data center team to restore temperatures to normal operating levels. During this time, connected services may experience intermittent interruptions while we are still mitigating the issue. We sincerely appreciate your patience during this time.

  • Identified 4 days ago · Aug 13, 2026 07:34 EDT

    We are currently monitoring an issue affecting the Phoenix data center, where elevated ambient temperatures have been detected. The facility team is actively working to restore temperatures to normal operating levels. During this period, some equipment may reboot, which can result in temporary service interruptions or monitoring alarms. Impact Some services hosted in the Phoenix data center may experience intermittent connectivity or brief interruptions. Equipment reboots may occur while the issue is being addressed. Monitoring alarms may be triggered during this period. At this time, no critical services have been reported as affected. Our infrastructure and facility teams are closely monitoring the situation and working with the data center provider to minimize any impact. We appreciate your patience and understanding while this issue is being resolved.