We are still seeing a bit of increased latency but SSLs are issuing now.
Posted Sep 14, 2025 - 05:37 EDT
Monitoring
We got the following update from Cloudflare:
Our Engineering team has been able to largely address the initial latency issues and has been persistently working on the issue since the initial declaration. Certificates are in the process of being issued, but there is still an ongoing delay due to a large number of pending certificate orders. Currently certificates are being issued and should start begin showing as active shortly as the backlog of pending certificates continues to be processed.
Posted Sep 13, 2025 - 18:50 EDT
Update
We just received the following update from Cloudflare:
Hello,
Thank you for reaching out, and I’m truly sorry for the disruption this has caused.
We’re currently aware of an ongoing Cloudflare incident impacting the Custom Hostnames / SSL for SaaS API, which may lead to errors or delays when provisioning or validating hostnames. Our engineering team is actively engaged and working with Cloudflare to resolve this as quickly as possible.