[Cloudflare] CDN Cache Purge Issues

Incident Report for Rocket.net

Resolved

This incident has been resolved.
Posted Sep 08, 2025 - 12:25 EDT

Monitoring

Cloudflare seems to have implemented a fix, we will continue to monitor this.
Posted Sep 08, 2025 - 12:24 EDT

Investigating

Cloudflare cache purge is failing at a high rate on the Cloudflare API. We have a support case open with them and will keep updating status until resolved
Posted Sep 08, 2025 - 12:14 EDT
This incident affected: Cloudflare CDN/Cache.